10/11/13 Summit Browser Compatibility

|
UITS has released the following list of browsers and versions that are compatible with Summit.  
Chrome 12+
Internet Explorer 9.x 
Firefox 6+
Firefox 17+




About this Entry

This page contains a single entry by Clark, Norma published on October 11, 2013 9:54 AM.

10/9/13 Summit issues with Google Chrome was the previous entry in this blog.

10/15/2013 Empac Maintenance scheduled is the next entry in this blog.

Find recent content on the main index or look in the archives to find all content.

Subscribe to feed Subscribe to this blog's feed